[BUG] Desktop Pro browsing for a license file not working

Follow

Problem

Desktop pro does not allow you to use the file browser to upload a license file. If you try to do so, after the file browser closes, the "Select License File" dialog still says "No file selected".

422010905-5286e435-7b80-409a-94ba-2d9cd8eca21a.png

Root Cause

Newer versions of Electron no longer augment File JavaScript objects with the path of the underlying file; instead, it needs to be resolved via a new API: https://www.electronjs.org/docs/latest/api/web-utils

 

Steps to reproduce

  1. Run Desktop Pro on a system without a valid license.
  2. Click "Select license file..." button to bring up "Select License File" dialog.
  3. Click "Browse..." button to bring up file browser.
  4. Choose a license file.

 

Workaround

You can paste or type the path into the text box.

 

Status

A bug report has been opened regarding this issue, but it has not yet been resolved.

Comments